Repository update for Meltdown and Spectre



This article on RedHat explains the Meltdown and Spectre vulnerability.

Recently there was a release for fixing these vulnerabilities on the Redhat and CentOS repositories.

Since we provide our own repository, these updates are now also available there.


Who needs to install this?

Customers who run the TrustBuilder appliance, meaning people who have the version 8 or 9 of TrustBuilder.


How to install the fix?

TrustBuilder >= 8.0

Before you do the update you need to remove a line in the .repo file:

Go to /etc/yum.repo.d/trustbuilder* and remove the exclude=kernel* in the whole file.

To install the fix you need to run the following commands:

sudo yum clean all

sudo yum update kernel-* perf-* python-pref-*


What packages are installed?

The following packages need to be installed to fix the vulnerabilities:

  • kernel-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-abi-whitelists-3.10.0-693.11.6.el7.noarch.rpm

  • kernel-debug-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-debug-devel-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-devel-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-doc-3.10.0-693.11.6.el7.noarch.rpm.

  • kernel-headers-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-tools-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-tools-libs-3.10.0-693.11.6.el7.x86_64.rpm

  • kernel-tools-libs-devel-3.10.0-693.11.6.el7.x86_64.rpm

  • perf-3.10.0-693.11.6.el7.x86_64.rpm (may not be installed, as it is not standard on the appliance)

  • python-perf-3.10.0-693.11.6.el7.x86_64.rpm (may not be installed, as it is not standard on the appliance)

Have more questions? Submit a request